Category Archives: Timing issues

Lifting the Skirt

Before powering the Amiga I wanted to check the state of the internals


It’s always a good idea to have a quick peek of the overall condition of the hardware before powering it up for the first time — especially as it may have been laying dormant for few decades.

Seems that someone has been here before

Commodore really played it safe with the RF shielding of the unit. I have seen microwave ovens with less RF shielding than this…

RF-shieding

My Amiga didn’t come with a 2.5″ hard drive so I added the IDE CF drive, which was something I was planning to do anyway.

Of with the shielding

The overall condition of the motherboard is really good. No leaking caps or burnt out resistors in sight.

Absolutely no corrosion on the motherboard — as it had just arrived from the factory. Seems that the unit has also been recapped at some point.

The motherboard revision is 1D4 which was the last revision made by Commodore, the later ones made by Escom were 2B.

A1200 motherboard revision details

For the common timing issues and related fixes check this.

Other details on motherboard revisions are available here.

The previous owner of this Amiga had done a brilliant job of keeping the old lady in good shape.

Interesting design choice for the mouse port

Nice to see the original quality assurance markings made the assembly line workers some twenty odd years ago.

QA Markings

Let’s get the Amiga started — I couldn’t find any issues on the Amiga nor the power brick.

After partitioning the HD and installing Workbench using WinUAE, I had the Amiga boot up just fine.

Avail and cpu details

The specs of A1200 — there is still quite some room for improvement here 😉